Upgrading PostgreSQL 8.3 to 8.4 on Squeeze

Currently upgrading Debian Lenny to Squeeze is not that easy, because PostgreSQL 8.3 from Lenny is getting to be removed while PostgreSQL 8.4 won’t be installed because of some dependency issues: 

# apt-get install postgresql-8.4 postgresql-8.4-postgis postgresql-contrib-8.4
Reading package lists… Done
Building dependency tree      
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
  postgresql-8.4: Depends: libgssapi-krb5-2 (>= 1.8+dfsg) but it is not going to be installed
                  Depends: libkrb5-3 (>= 1.6.dfsg.2) but it is not going to be installed
                  Depends: libpq5 (>= 8.4~0cvs20090328) but 8.3.11-0lenny1 is to be installed
                  Depends: postgresql-client-8.4 but it is not going to be installed
  postgresql-contrib-8.4: Depends: libpq5 (>= 8.4~0cvs20090328) but 8.3.11-0lenny1 is to be installed
E: Broken packages

Well, yes, I know Squeeze is still Testing and such, but as libkrb5-3 and libgssapi-krb5-2 are required but seem to be unavailable, I wonder when this issue will get solved? There seems no bug report for postgresql-8.4, libkrb5-3 or libgssapi-krb5-2. Is that for a reason? Or is the reason for uninstallable postgresql-8.4 something else?


# apt-cache policy postgresql-8.4
  Installed: (none)
  Candidate: 8.4.4-2
  Version table:
     8.4.4-2 0
        500 http://ftp.de.debian.org squeeze/main Packages

# apt-cache policy libkrb5-3
  Installed: 1.8.3+dfsg~beta1-1
  Candidate: 1.8.3+dfsg~beta1-1
  Version table:
 *** 1.8.3+dfsg~beta1-1 0
        500 http://ftp.de.debian.org/debian/ squeeze/main amd64 Packages
        100 /var/lib/dpkg/status

This issue seems to be caused by #596678. Thanks Rhonda & Martin!


9 thoughts on “Upgrading PostgreSQL 8.3 to 8.4 on Squeeze

  1. Looks like the system is
    Looks like the system is still configured for Lenny.
    apt-cache policy will tell usmore.

    1. I’ve added information about
      I’ve added information about output of apt-cache policy postgresql-8.4 .

  2. Maybe playing with aptitude
    Maybe playing with aptitude and then with aptitude why and aptitude why-not could get your answer ?

    In a recently installation of squeeze postgres install without any conflict

    1. # aptitude why
      # aptitude why postgresql-8.4
      i drupal6 Recommends mysql-server | postgresql
      p postgresql Depends postgresql-8.4
      # aptitude why-not postgresql-8.4
      Unable to find a reason to remove postgresql-8.4.

      Anyway, I believe you that a clean install of psql 8.4 will work, but I need to upgrade from 8.3 to 8.4 and I don’t know if pgsql will upgrade the cluster when psql 8.3 is removed before the installation of 8.4?

  3. What gives apt-cache policy
    What gives apt-cache policy libkrb5-3? The package is in Squeeze and should be installable.

    1. I’ve added the output to the
      I’ve added the output to the blogpost…

  4. Upgrade works here – but yes,
    Upgrade works here – but yes, not flawlessly. postgresql-8.3 will have to get removed because of libkrb53 removal due to breaks from libkrb5-3, but upgrade to postgresql-8.4 works.

    If you want to have both 8.3 and 8.4 installed for an upgrade path and data transition I suggest to install the postgresql-8.4 packages from lenny-backports on lenny _prior_ to the upgrade to squeeze. Then you can do the pg_upgradecluster switchover and after that do the real squeeze upgrade with removing postgresql-8.3 all together.

    I guess this suggestion should be added to the release notes – will try to coordinate with the writers and Martin Pitt (postgres maintainer) to get that included. Thanks for bringing up the issue!


  5. Thanks for pointing this out.
    Thanks for pointing this out. This is a severe bug in the libkrb5-3 packaging, I reported it in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=596678 .

    Using backports is of course a helpful straw here, but I suppose many folks won’t start looking into release notes and similar HOWTOs until it’s too late. Also, it would be a shame to knowingly break the Lenny->Squeeze upgrade, so let’s try to get this fixed properly.

Comments are closed.