Upgrading request-tracker 3.6 to 3.8 on Squeeze

Today I had some problems with request-tracker in version 3.6 on Squeeze, coming from Lenny: although I was able to write mails to the ticket system and was able to receive mails from it when creating new tickets, I was unable to send replies to tickets to the requestor. Instead of dealing around with 3.6 I tried to upgrade to rt 3.8. Basically the upgrade went fairly well, except for my PostgreSQL database. It depends on postgresql-client which is a virtual package for postgresql-client-8.4. As learned lately postgresql-8.4 is somewhat uninstallable on Squeeze at the moment.

So, I needed to make some sort of backport for rt3.8-db-postgresql_3.8.8-3_all.deb, which was quite easy. Instead of

Depends: ${misc:Depends}, libdbd-pg-perl (>= 1.41),
 postgresql-client (>= 7.4)
Suggests: postgresql | postgresql (>= 7.4)

I changed the lines to this: 

Depends: ${misc:Depends}, libdbd-pg-perl (>= 1.41),
 postgresql-client-8.3 (>= 7.4)
Suggests: postgresql-8.3 | postgresql (>= 7.4)

Now I was able to install request-tracker3.8 successfully, upgrade the database and enjoy the new shiny version of rt. I’m unsure whether I needed to edit/save the Respond scrips as well to make the mail sending again or not. But that shouldn’t be big show blocker either.

Anyway, I think I’ll write a bug report for rt 3.8 tomorrow… It’s always fun to find yet another bug when a new release is upcoming… 🙂

UPDATE:
Bug report filed as #596926

Published

3 comments

  1. Hey! … excelent post!
    I had

    Hey! … excelent post!

    I had some problems with RT 3.6 too about emails.

    I would like to upgrade to RT 3.8 version.

    Can you guide me in the process ?

    I have Debian Lenny with Mysql backend.

    Take care !

    José

    1. Sorry, I have no experience
      Sorry, I have no experience with RT and MySQL backends…

Comments are closed.