You are here

M68k Porters Meeting 2008 in Kiel is over

Yesterday a server at work needed some care - which was the reason why I had to leave the m68k porters meeting early. It was intented to migrate the filesystem to a RAID1 setup instead of using just a single disk.

Of course I tested everything in advance and it worked. Sadly Murphy did hit the scene as well and the previously tested upgrade path failed: somehow the RAID couldn't be started and the boot progress stopped.

Actually, the error was this one:

Failure: failed to load Module 1 no such module

Useless to say that the initrd was uptodate and included all necessary modules!

Luckily someone else happened to stumble upon the same problem last year and it was well documented on debian-user mailing list in a thread between Andrew Sackville-West and Martin F. Krafft , properly archieved by some mirrors.

So, the problem was in some mdadm script that was executed during boot process and which parsed the ARRAY definition in that way that the kernel modules couldn't get loaded.
If you follow the thread on that mailing list you'll come to the following hint:

Try the following patch agaist
/usr/share/initramfs-tools/hooks/mdadm. It ensures that RAID levels
include the word 'raid'. I think your mdadm.conf may say stuff like
level=5, when it should say level=raid5 or not specify level= at
all.

And yes, my ARRAY definition in mdadm.conf just stated level=1 as well. So after setting it to level=raid1 everything worked again.

Thanks, Andrew and Martin for solving that problem a year ago! :-)

Kategorie: 
 

Add new comment

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer