You are here

Fritzbox

Fritzbox, Fernwartung VPN und eigener DynDNS

Ich hab mir mal wieder ein kleines Problemchen ausgedacht. Gegeben sind zwei Fritzboxen, ein Rootserver und zwei Dialup-Verbindungen. Die Fritzboxen sollen untereinander und jeweils zum Rootserver ein VPN per IPsec aufbauen. Zwischen den beiden Fritzboxen funktioniert das ja per der AVM-eigenen Software ja problemlos mit der Einrichtung. Wenn man nun zu einem Rootserver mit Strongswan eine Verbindung aufbauen will, muss man laut Anleitung im Internet die Config-Dateien etwas anpassen. Soweit scheint es mehr oder weniger Standard zu sein.

Das Lustige kommt nun: gleichzeitig will ich noch von DynDNS.org weg- und hin zu einer Self-Hosted-Lösung kommen. Auch dafür gibt es einige Howtos im Netz und die Fritzbox unterstützt das ja auch. Das Problem ist nun aber die VPN-Verbindung, die per se erstmal einen Hostnamen als FQDN in der Config voraussetzt. Wenn nun aber das Subnetz, in dem der Nameserver steht, per IPsec abgesichert ist, dann wird das Update solange nicht funktionieren bis die IPsec Verbindung aufgebaut ist. Ohne DNS Update aber kann die IPsec Verbindung nicht aufgebaut werden. Also eine Kausalitätsschleife, sozusagen.

Falls also jemand eine Lösung für dieses Problem hat, würde ich mich über Ideen oder Hinweise freuen. :-)

Kategorie: 
 

Fritz!box 7390 und WLAN mit dem Mac

Letzte Woche hab ich mir eine Fritz!box 7390 gekauft, da sich der bisherige Router (Speedport w701v) ab und zu mal aufgehangen hat. Außerdem zählten als Vorteile für die Fritzbox die funktionierende integrierte Telefonanlage, die IPv6-Fähigkeit, die Möglichkeit VPNs aufzubauen, sowie die Fähigkeit WLAN im 2.4 und auch im 5 GHz Band zu betreiben.

Allerdings ist die Freude etwas getrübt, was die Nutzbarkeit des 5 GHz WLANs angeht. Denn das funktioniert mit dem Mac nun überhaupt nicht zufriedenstellend. Prinzipiell funktioniert die Verbindung über 5 GHz, also nach 802.3a/n, aber bereits nach kurzer Zeit kann keine Verbindung mehr hergestellt werden bzw. verliert der Rechner seine IP-Adresse, obwohl das Icon in der Menüleiste noch WLAN-Verbindung als hergestellt anzeigt. Erst wenn OSX sich dann eine Autoconf-IP zuweist, steht dort ein Ausrufezeichen als Hinweis, daß etwas nicht stimmt.

Eine Internetrecherche bringt schnell zu Tage, daß das kein neues und vor allem aber ein bisher ungelöstes Problem ist, wo sich wohl weder Apple noch AVM als Hersteller der Fritzbox irgendwie so recht zuständig sehen, es mal zu lösen. WLAN mit 2.4 GHz funktioniert hingegen offenbar problemlos. Ich habe keine Ahnung, was an 5 GHz so grundlegend anders sein soll, daß es dort zwischen Apple und Fritz!box solche Probleme gibt. Eine technisch fundierte Beschreibung oder Analyse des Fehlers habe ich bisher auch noch nicht gefunden.

Vielleicht hat ja aber ein Leser dieses Blogs einen hilfreichen Hinweis für mich?

UPDATE 10. März 2012: 
Mit dem aktuellen Firmware-Update 84.05.20 scheint WLAN mit meinem MacBookPro und 5 GHz zu funktionieren. Das WLAN läuft nun schon längere Zeit auf 5 GHz und es kam noch zu einem Verbindungsabbruch, was sonst immer schon nach 10-30 Minuten der Fall war. 

Kategorie: 
 

Pages

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer